Friday, January 11, 2008

How to create a tunnel and connect 2 different ip subnets

This is a handy trick if you want to connect 2 different subnets (belonging to 2 routers that are some hops away) and you can't use your own ip addresses.

Router1 - RouterX - RouterY - Router2

Router 1


interface Loopback0
ip address 100.1.6.6 255.255.255.0
!
int Serial0/0
ip address 100.2.6.6 255.255.255.0
!
interface Tunnel0
ip unnumbered Loopback0
tunnel source Serial0/0
tunnel destination 100.2.7.7
!
router ospf 111
passive-interface Loopback0
network 100.1.6.6 0.0.0.0 area 111


Router 2

interface Loopback0
ip address 100.1.7.7 255.255.255.0
!
int Serial0/0
ip address 100.2.7.7 255.255.255.0
!
interface Tunnel0
ip unnumbered Loopback0
tunnel source Serial0/0
tunnel destination 100.2.6.6
!
router ospf 111
passive-interface Loopback0
network 100.1.7.7 0.0.0.0 area 111


OSPF can work fine between different subnets, as long as ip unnumbered is used.

Just keep in mind that if you're already using OSPF in these two routers, then you have to use a different OSPF process for this tunnel link. Also make sure you define the tunnel interfaces as passive under the other (main) process.

You can do the same (probably easier) if you use RIP and configure "no validate-update-source" under its process.

EIGRP doesn't seem to provide a similar feature.

No comments:

Post a Comment

 
Creative Commons License
This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 United States License.
Creative Commons License
This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Greece License.